The huge forum crash....

Post Reply
User avatar
DS-10 Dominator
Site Admin
Posts: 1390
Joined: Sat Feb 27, 2010 1:20 am
Location: Amsterdam, Netherlands

The huge forum crash....

Post by DS-10 Dominator » Sat Jan 14, 2017 5:17 am

Dear people, friends, synth nerds...

Wow, It's been something like 3 years now, and I still don't know what exactly happened. And I'm so sorry I didn't find the time and energy to fix this earlier!

Story. Late 2014, DS10forum.com possibly got hacked, in any case it crashed and lost most of its posts. More specifically: I was left with 2 pieces of Forum: A) A database (backup) of roughly 2010-2013 and B) The crashed database: which contained the posts of roughly 2014, this part of the crashed forum was still accessible.

I assume it was hacked because updating phpBB never seemed to work for me (I really did try! don't why it would just give me errors :\ ), which made it a matter of time before someone (or some bot) would exploit a security bug. I recommend you all to change your passwords here. This is a good habit anyway. And try not to use the same password everywhere on the net! You can use an automatic password tool like Lastpass to not have to remember all your passwords.

The forum is now running on the latest phBB 3.2, with the old database backup loaded, meaning that it misses all posts from 2014 :cry:. If I ever figure out how to merge these two databases I might be able to import the posts from 2014. Archive.org also has several backups DS10forum, some of their 'captures' (as they call their "backups") show more pages than others. You can find back most post there.

I hope to welcome a lot of you back. And I have an awesome compilation idea... more soon... I'm dead tired now. :geek:
soundcloud.com/auxpulse soundcloud.com/ds10dominator

User avatar
Sinqlogue
Posts: 249
Joined: Tue Mar 02, 2010 9:50 am
Location: Kockengen

Re: The huge forum crash....

Post by Sinqlogue » Sat Jan 14, 2017 8:36 am

Welcome back!

This is a very pleasant surprise. Gotta say I'm actually looking forward to what's coming up here.

My top Korg DS-10 days are kinda over, but maybe this great community here can help motivate my to pick it up.

Again kudos for you Rutger for saving this wonderful piece of Korg DS-10 history!
Image

User avatar
UncleBibby
Posts: 324
Joined: Thu Jan 06, 2011 1:23 am
Location: Canada
Contact:

Re: The huge forum crash....

Post by UncleBibby » Sun Jan 22, 2017 10:13 pm

wow lol... its back... too bad i mostly stick to other stuff now, like ableton live and korg gadget... maybe there should be a korg gadget section of this forum?

EDIT: okay there's already a section for korg gadget... neat.
Oonts-oonts-oonts-oonts...

User avatar
NeoS
Posts: 109
Joined: Sun May 23, 2010 3:39 am
Location: Seattle, USA
Contact:

Re: The huge forum crash....

Post by NeoS » Fri Jan 27, 2017 6:15 pm

Nice to see that you've resurrected the forum, Rutger. I use the DS-10 occasionally and it would be neat to see the community gain some activity.
genius is 1% inspiration 99% perspiration (thomas edison)

User avatar
D A Payne
Posts: 156
Joined: Thu May 05, 2011 8:05 am
Location: UK

Re: The huge forum crash....

Post by D A Payne » Fri Jan 27, 2017 8:35 pm

hAHA WOW, haven't looked at this site for like over a year and randomly decided to check it today and what do you know, she's alive!
Nothing to do with busses

User avatar
DS-10 Dominator
Site Admin
Posts: 1390
Joined: Sat Feb 27, 2010 1:20 am
Location: Amsterdam, Netherlands

Re: The huge forum crash....

Post by DS-10 Dominator » Tue Jan 31, 2017 12:47 am

Sinqlogue wrote:
Sat Jan 14, 2017 8:36 am
Welcome back!

This is a very pleasant surprise. Gotta say I'm actually looking forward to what's coming up here.

My top Korg DS-10 days are kinda over, but maybe this great community here can help motivate my to pick it up.

Again kudos for you Rutger for saving this wonderful piece of Korg DS-10 history!
Cheers, good you're still around :).
soundcloud.com/auxpulse soundcloud.com/ds10dominator

User avatar
DS-10 Dominator
Site Admin
Posts: 1390
Joined: Sat Feb 27, 2010 1:20 am
Location: Amsterdam, Netherlands

Re: The huge forum crash....

Post by DS-10 Dominator » Tue Jan 31, 2017 12:49 am

UncleBibby wrote:
Sun Jan 22, 2017 10:13 pm
wow lol... its back... too bad i mostly stick to other stuff now, like ableton live and korg gadget... maybe there should be a korg gadget section of this forum?

EDIT: okay there's already a section for korg gadget... neat.
Welcome back :)

I myself use Ableton mostly as well. For both my 8-bit music and my contemporary music. But I'd love to take part in a compilation once more.
soundcloud.com/auxpulse soundcloud.com/ds10dominator

User avatar
DS-10 Dominator
Site Admin
Posts: 1390
Joined: Sat Feb 27, 2010 1:20 am
Location: Amsterdam, Netherlands

Re: The huge forum crash....

Post by DS-10 Dominator » Tue Jan 31, 2017 12:53 am

NeoS wrote:
Fri Jan 27, 2017 6:15 pm
Nice to see that you've resurrected the forum, Rutger. I use the DS-10 occasionally and it would be neat to see the community gain some activity.
Glad to hear so! Let's do that...
soundcloud.com/auxpulse soundcloud.com/ds10dominator

User avatar
DS-10 Dominator
Site Admin
Posts: 1390
Joined: Sat Feb 27, 2010 1:20 am
Location: Amsterdam, Netherlands

Re: The huge forum crash....

Post by DS-10 Dominator » Tue Jan 31, 2017 12:53 am

D A Payne wrote:
Fri Jan 27, 2017 8:35 pm
hAHA WOW, haven't looked at this site for like over a year and randomly decided to check it today and what do you know, she's alive!
Woohoo :)
soundcloud.com/auxpulse soundcloud.com/ds10dominator

User avatar
DS-10 Dominator
Site Admin
Posts: 1390
Joined: Sat Feb 27, 2010 1:20 am
Location: Amsterdam, Netherlands

Re: The huge forum crash....

Post by DS-10 Dominator » Tue Jan 31, 2017 12:54 am

Did you guys notice errors like "SERVICE UNAVAILABLE?" on the forum now?

I'm discussing with my host what this could be. I think they tightened the security too much, so if you click to fast through the forum it sometimes blocks you :\.
soundcloud.com/auxpulse soundcloud.com/ds10dominator

User avatar
NeoS
Posts: 109
Joined: Sun May 23, 2010 3:39 am
Location: Seattle, USA
Contact:

Re: The huge forum crash....

Post by NeoS » Wed Feb 01, 2017 4:38 pm

Yeah I have noticed that. It seems to happen more randomly, not necessarily in relation to how fast you navigate around. For example, once it happened to me when I was navigating to the site for the first time that day.
genius is 1% inspiration 99% perspiration (thomas edison)

User avatar
DS-10 Dominator
Site Admin
Posts: 1390
Joined: Sat Feb 27, 2010 1:20 am
Location: Amsterdam, Netherlands

Re: The huge forum crash....

Post by DS-10 Dominator » Thu Feb 02, 2017 1:22 am

NeoS wrote:
Wed Feb 01, 2017 4:38 pm
Yeah I have noticed that. It seems to happen more randomly, not necessarily in relation to how fast you navigate around. For example, once it happened to me when I was navigating to the site for the first time that day.
Cheers, thanks for reporting this. I drew the same conclusion. I hope my host will fix it soon.
soundcloud.com/auxpulse soundcloud.com/ds10dominator

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest